Basic Switch Template

service timestamps debug datetime msec
service timestamps log datetime msec
!
service password-encryption
!
hostname XXX
!
username XXX privilege 15 secret 0 XXX
aaa new-model
aaa authentication login default local
aaa authorization exec default local
!
!Trunks
interface GigabitEthernet1/1
description Connection to XXX
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
shut
!
interface VlanXXX
description Managment vlan
ip address X.X.X.X X.X.X.X
no shut
!
banner exec ^CC
---------------------------------------------
You have accessed : $(hostname).$(domain)
You are accessing line: $(line)
---------------------------------------------
^C
banner motd ^CCC
****************************************
* *
* THIS DEVICE IS PART OF A PRIVATE NETWORK *
* *
* * * * * * * * * * * * * * * * * * * * * * * * * *
* Unauthorised access or use of this equipment *
* is prohibited and constitutes an offence *
* under the Computer Misuse Act of 1990. *
* If you are not authorised to use this *
* system, terminate this session now. *
* * * * * * * * * * * * * * * * * * * * * * * * * * *
^C
!
line con 0
privilege level 15
line vty 5 15
privilege level 15
!
end

About Alexis Katsavras

Working as Freelance Cisco Unified Communications Consultant in the UK. www.NetPacket.co.uk