Router base QoS

ip access-list extended CONTROL
.remark Match VoIP Control Traffic
.remark SCCP
..permit tcp any any range 2000 2002
.remark H323 Fast Start
..permit tcp any any eq 1720
.remark H323 Slow Start
..permit tcp any any range 11000 11999
.remark H323 MGCP
..permit udp any any eq 2427
.ip access-list extended VIDEO
.remark Match Video Streaming Traffic
..permit ip any any dscp cs4
..permit ip any any dscp af41
.ip access-list extended VOICE
..remark Match the UDP ports that VoIP uses for Bearer Traffic
.permit udp any any range 16384 32767
!
class-map match-all VOICE-RTP
.description VOIP Bearer Traffic
.match access-group name VOICE
class-map match-all VOICE-CONTROL
.description VOIP Control Traffic (SCCP, H225, H254, MGCP)
.match access-group name CONTROL
class-map match-all VIDEO-CONF
.description Video Conference Traffic
.match access-group name VIDEO
!

OR if no access list are been used
!
class-map match-any VOICE-RTP
match ip dscp ef
match protocol rtp audio
class-map match-any VOICE-CONTROL
match ip dscp cs3
match protocol h323
match protocol mgcp
match protocol sip
match protocol skinny
!
policy-map VOIP-QOS
.description Set DSCP for VOIP Control, ICCS and Bearer Traffic
..class VOICE-RTP
...priority percent 33
...set ip dscp ef
..class VOICE-CONTROL
...bandwidth 16
...set ip dscp cs3
..class VIDEO-CONF
...bandwidth 460
...set ip dscp af41
..class class-default
...fair-queue
!
interface Serial0/1/0
.bandwidth 1000000
.ip address 10.x.x.x 255.255.255.0
.no cdp enable
.service-policy output VOIP-QOS

About Alexis Katsavras

Working as Freelance Cisco Unified Communications Consultant in the UK. www.NetPacket.co.uk