H323 template

service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec show-timezone
service password-encryption
!
hostname XXXX
!
card type e1 0 0
!
clock timezone GMT 0
clock summer-time BST recurring last Sun Mar 2:00 last Sun Oct 2:00
network-clock-participate wic 0
!
no ip domain lookup
ip domain name xxx.xxx
!
!For ISDN
isdn switch-type primary-net5
!For PBX
isdn switch-type primary-qsig
!
voice-card 0
no dspfarm
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
h323
call preserve
h245 caps mode restricted
modem passthrough nse codec g711ulaw
sip
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
voice class h323 1
h225 timeout tcp establish 3
!
voice translation-rule 100
rule 1 /^315\(...\)$/ /5\1/
!
voice translation-rule 101
rule 1 /^5\(...\)$/ /01382315\1/
!
voice translation-rule 200
rule 1 /\(^......$\)/ /9\1/
rule 2 /\(^..........$\)/ /900\1/ type international international
rule 3 /\(^..........$\)/ /90\1/
rule 4 /\(^...........$\)/ /900\1/
rule 5 /\(^............$\)/ /900\1/
!
voice translation-profile PSTN-IN-1-0
translate calling 200
translate called 100
!
voice translation-profile PSTN-OUT-1-0
translate calling 101
!
!
username XXX privilege 15 secret 0 XXX
!
controller E1 0/0/0
pri-group timeslots 1-X
description "ISDN E1 0-X channels Connection from ISDN to GW ***
!
interface FastEthernet0/0
description Connection to HQ LAN
ip address x.x.x.x x.x.x.x
no ip redirects
duplex auto
speed auto
h323-gateway voip bind srcaddr x.x.x.x
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
no snmp trap link-status
isdn switch-type primary-qsig
isdn incoming-voice voice
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 X.X.X.X
!
no ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
access-list 10 permit X.X.X.X
access-list 10 permit X.X.X.X
access-list 10 permit X.X.X.0 0.0.0.255
access-list 10 permit X.X.X.0 0.0.0.255
snmp-server community "CommunityString" RO 10
snmp-server community "CommunityString" RW 10
snmp-server location XXXXXXX
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps envmon
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps event-manager
snmp-server enable traps cpu threshold
snmp-server host X.X.X.X "CommunityString"
!
voice-port 0/0/0:15
echo-cancel coverage 48
no vad
cptone GB
bearer-cap Speech
translation-profile incoming PSTN-IN-1-0
translation-profile outgoing PSTN-OUT-1-0
!
dial-peer voice 1 pots
description *** INBOUND POTS PEER ***
incoming called-number .
direct-inward-dial
port 0/0/0:15
!
dial-peer voice 2 voip
description *** INBOUND VOIP PEER ***
voice-class codec 1
incoming called-number .
dtmf-relay h245-alphanumeric
fax rate disable
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 5002 voip
tone ringback alert-no-PI
description *** SECOND CCM NODE SUB 1***
preference 1
destination-pattern X...
progress_ind setup enable 3
progress_ind alert enable 8
voice-class codec 1
voice-class h323 1
session target ipv4:x.x.x.x
dtmf-relay h245-alphanumeric
fax rate disable
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 5001 voip
tone ringback alert-no-PI
description *** CCM NODE PUB ***
preference 2
destination-pattern X...
progress_ind setup enable 3
progress_ind alert enable 8
voice-class codec 1
voice-class h323 1
session target ipv4:x.x.x.x
dtmf-relay h245-alphanumeric
fax rate disable
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 9 pots
tone ringback alert-no-PI
description *** ALL OUT PEER ***
destination-pattern 9T
progress_ind setup enable 3
progress_ind alert enable 8
port 0/0/0:15
!
dial-peer voice 10 pots
description *** 999 CALLS ***
destination-pattern 999
progress_ind setup enable 3
progress_ind alert enable 8
port 0/0/0:15
forward-digits all
!
dial-peer voice 11 pots
description *** 9.999 CALLS ***
destination-pattern 9999
progress_ind setup enable 3
progress_ind alert enable 8
port 0/0/0:15
forward-digits 3
!
!
banner motd ^CCCCC
*************************************************
* *
* THIS DEVICE IS PART OF A PRIVATE NETWORK *
* *
* * * * * * * * * * * * * * * * * * * * * * * * *
* Unauthorised access or use of this equipment *
* is prohibited and constitutes an offence *
* under the Computer Misuse Act of 1990. *
* If you are not authorised to use this *
* system, terminate this session now. *
* * * * * * * * * * * * * * * * * * * * * * * * *
^C
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh

About Alexis Katsavras

Working as Freelance Cisco Unified Communications Consultant in the UK. www.NetPacket.co.uk